A cheap wireless laser printer with 3rd party toner is the way to go

Yeah, I’ve had problems trying to get a Brother printer working on Linux. Tho their windows drivers aren’t actively hostile, which is a pleasant surprise for a printer manufacturer.

absofuckinglutely. my brother l234dw is great. toner is $8/pack. fuck inkjets.

That’s not bad advice, but I bought an HL-2140 for $49 over a decade ago and have found the Linux and Windows drivers from Brother to work acceptably well. I know I’m one kernel update from them no longer working as they’ve never been updated in the time I’ve owned the printer–and they’re x86 only (32-bit).

You may notice that the HL-2140 is a wired only printer. But, that’s easily solved with a spare raspberry pi board. That’s what I’ve been doing for quite a while as well–before it was a raspberry pi, it was a repurposed ‘thin client’ AMD Geode 300MHz box. All the box needs to run is CUPS. It doesn’t need printer drivers as the clients will have those. My kids discovered something cool last week. It seems between CUPS/Avahi/ZeroConf and AirPrint, iOS devices can print to the printer. I’m not sure who’s doing the document rasterization (as the rpi doesn’t even know how), but it works.

The only risk to the drum is if you refill a cartridge and don’t empty out the wast toner such that it fills up and can’t hold any more. Then the priner won’t be able to clean off the drum properly and bad thing will start to happen–toner will go where toner should not…

If you’re interested in how many pages you have printed, just tap the big button on the front twice quickly. It’ll print out a status page. There are special sequences to reset the toner and to reset the drum as well. And, yes, this printer likes to fake the toner going bad when it thinks the cart should be at EOL. But it’s not. Just push the button sequence and magically it’s all fine. Grrr…

I’ve been printing to my HL-2140 for over a decade from a variety of OSs. Linux has always been the easiest to configure. Windows is always a bit more painful as their installer insists that a USB only printer can’t possibly be reached over the network (clearly they missed out hearing about network printer servers which have been a thing for decades). The worst was MacOS. That was a nightmare. Seems there’s hidden menus you have to access to configure things. So glad to have that horrible OS off my network finally.

I have a Brother HL-L2300D, which is not wireless. In hindsight, I wish I had forked over the extra 30 bucks or so to get the wireless version, but an old laptop running Ubuntu works fine as a print server. Zero problems.

1 Like

I had trouble getting a new Brother printer to work with Linux. So I went to a website that has a list of all Linux compatible printers and then bought an old HP 1022 laserjet. It prints fast and quiet and compatible ink is dirt cheap. My mistake was not buying a wireless version.
Now if I can just find a nice old color laser printer that is WiFi

Got a spare Rpi board? Just install CUPS and plug it into the printer.

We were given an old Brother HL-2140 for free by my wife’s supervisor when said supervisor was cleaning out her garage. The problem was that it was the USB-only model. I set up a Raspberry Pi Zero W as a print server and it has been smooth sailing for the past 2 years.


I have an iX6820 which I think is a newer version of your machine. It’s not perfect, but it’s a really great value. I actually do my own ink refills (though I’m not sure I really save much over just buying third party cartridges) and it never complains. Mine does support WiFi - setup was a bit awkward, but once I got it connected it’s been stable.

1 Like

I have the same one, and just buy loose toner, and you pull off the cap and fill the old cartridge, and off you go.

Once in a while the print server needs to be reset; different Brother printers have different routines for that but the HL-2270DW’s is:

  • Turn off the printer.
  • Hold down the GO button while you turn it back on; keep holding it until all the lights go out.
  • Release the button, then press it six times.

Doing this will reset the print server to factory defaults, so you may need to reconfigure some settings.

1 Like

Thanks. I’ve done the first 55 things recommended in the manuals and online, and nothing will wake it up so far. It prints all its self diagnostics, but it won’t talk to the network. It is currently hardwired to the router by ethernet cable, and the router still does not see it. Quite frustrating.
Eventually I’ll go through the whole list a third and fourth time.

And I’m supposed to be the IT guy.

The cartridge has a proprietary chip, but it’s more of a “proprietary” chip because most 3rd party/remanufactured catridges seem to come with one nowadays. I’ve not had an issue with the 2350DW failing to recognize toner in the ~5 years we’ve been using it. Now, crappy 3rd party toner/drums that fail to properly attach to the page, or start smudging badly after a few hundred pages… Those, I’ve had.

That’s exactly the situation that the print server reset is meant to address. If that doesn’t work, you most likely have a hardware problem; does the port indicator light on the router turn on/off when you plug or unplug the cable from the printer?

One thing I did run into once with one of these printers (only once - it’s NOT common, but it does happen): something besides an Ethernet plug had been stuffed into the jack and bent a couple of the contact wires out of line. A bit of poking and pulling with a hooked paperclip got that printer talking on the network again.

Thanks for letting this old gal know that toner cartridges can be refilled. I’ve had a bottom of the line Samsung $40 model for ten or so years and it would be great to buy a bottle of toner and use it on the replacement if good ol’ cheapie bites the dust.

I had done the reset, more than once, cabled and uncabled, attached to the laptop, attached to the router. None of it affected the ability to have it show up on the network. The sniffer is working because I can see all my neighbors devices. The printer is working because it prints its dignotic pages correctly, though it never gets a realistic IP address.
Best I have got it going today is cabled to the router, reset printer, working as a wired device, and visible from the router Attached Devices page online.
Several attempts to disconnect and discover the printer since then have not worked. I have toggled off and on Printer Sharing. I have followed instructions to install as a local printer. I have poked the reset button on the printer that supposedly changes it from wired to wifi, and back. I have deleted and reinstalled the drivers a few times.
One would think that once my router can see the printer wired, it would only be a short trip to get it networked, but…
I might have to live with it parked next to the router instead of in my office. Thanks for trying - you obviously know what you’re doing.

It might just be evil, or haunted.

1 Like

This topic was automatically closed after 5 days. New replies are no longer allowed.