502. boingboing.net is being configured


#1

I haven’t seen anyone else mention this but for the last week when I refresh the home page I get the following more often than not:

  1. boingboing.net is being configured.

The page you are trying to access is protected by Project Shield, but recent configuration changes are propagating through our system. Try reloading the page in a minute.

Initially I assumed as the text says, that config changes are happening. But now I have seen this too many times for too many days.

I refresh the page every 30-60 minutes to see what is new. So I shouldn’t look like a DDOS attack I would think. Once I hit the error, any further refreshing is 100% to fail. if I go away for awhile and try later it has a good chance of working again.

I am accessing BB from work. there are a couple hundred people here but I’m pretty sure the entire company is not refreshing BB all day.

Not a big deal for me, but just thought I would mention it to make sure those running things are aware.


Project Shield
#2

It helps a bit to mention the sysadmin. Hey @orenwolf

I know I haven’t seen it but then I have been navigating out to the main site from here for too long so my experince isn’t normal.


#3

Thank you. Good point.


#4

Can you provide an example URL where you are getting that message?


#5

Here is the URL. Wrapped in code tags so it doesn’t get boxed.
https://boingboing.net/grid

Screen shot:


#6

That doesn’t make sense.

Does your ord use some sort of weird proxy or were the IP addresses for Boing Boing hardcoded at some point in the past?

I can’t see any reason you’d be getting this error from a boingboing.net URL. We do use Project Shield, but only for media.boingboing.net URLs (and if they weren’t working no images would be loading!).

I’m not sure what to tell you at this point. Do you know anything about your work’s network setup?


#7

I don’t use any proxies and I am not aware of IT doing so. I’ve never had a reason to hard code BB IP and IT sure wouldn’t.

They are for sure running some security and filtering on web traffic. For example, Sometime ago I tried to follow a link that ended up going to a tumblr post. But after a few seconds of experimenting it was clear IT blocks any and all access to tumblr (no big loss). Tumblr get a host not found error from my desktop but works from my phone over cell connection just fine.

I suppose something they are doing could be causing Project Shield grief.

If it’s just me and my stupid IT mucking with things no problem. My main concern was that this might be something that was effecting many people on BB and no one was speaking up. if no one pops up saying me too then it probably is my local IT.

Thank you, Ken.


#8

We’ve seen weird things like https everywhere rewriting our URLs to specific IPs, or the wrong CDN in the past.

I think what’s happening here is that your requests for /grid are going to media.boingboing.net instead of boingboing.net. Project shield isn’t expecting that (and in fact, our origin there can’t serve dynamic content) so you get that rather misleading message from them.

If you’re running a curl-equipped OS at work, I’d love to see the output of

curl -svo /dev/null https://boingboing.net/grid

but totally understand if that’s not possible. I’d like to try and figure out the root cause and see if it’s something I can fix on this end or not.

Thanks for the heads-up, regardless.


#9

Someone else started a topic in the general category about it, earlier today:


#10

Got this when going to the front page:

  1. boingboing.net is being configured.

The page you are trying to access is protected by Project Shield, but recent configuration changes are propagating through our system. Try reloading the page in a minute.
Free DDoS Protection from Project Shield

I’m guessing this is temporary while project shield is being installed. But does that mean that google will know everything I post on BBS?


#11

I think it does already… My BBS profile comes up when I ego search. I gave up caring mostly from being a white male also my name and address etc are all searchable already thanks to owning a house.


#12

Let me know if you’re still getting this tomorrow. If you are, please do try and send over the curl results if you can. You can also email bbshelp@boingboing.net with the results if you’d rather not have the output public.

Thanks for your help.


#14

I emailed the curl output.


#15

Thanks for that!

So, it looks like the request correctly went to Fastly, not project shield. So the issue isn’t at the network level. Can you try clearing out your browser caches (or try another browser you don’t normally use to connect to Boing Boing) and try again?


#16

Work has been hectic today so I haven’t had a chance to try your suggestions yet but I will.

What about this line at the end of the output? There is the media url.

< access-control-allow-origin: https://media.boingboing.net

Edited to add:
I cleared the browser cookies for BoingBoing.net and restarted Firefox and have not seen the issue repeat since then but today has been an abnormally busy day for me. Hopefully tomorrow I can get back to reading BB all day for a more accurate test.


#17

This is normal. We are letting browsers know that media.boingboing.net is allowed to execute javascript for BoingBoing.

I’m glad that the cache clear appears to have helped. Here’s hoping that’s all that was needed!


#18

I will let you know if I see the issue again. If not you can assume this is valid fix for any other that hit this issue.


#19

Just happened again to me. BB has been working for me for the last few days. I’ll be sending you the curl results by email.


ETA
Wait… when I run curl the output is fine. When I load the page in chrome, the output is fine. But in Firefox (my usual browser), I get the project shield error. Clearing the cache has no effect. So, I am sending you the HAR output from firefox. Hope this can help


#20

What Firefox extensions do you use?


#21

Too many to count…but try, I will.


Here they are:

  • Facebook container
  • ColorZilla
  • MDN Code search
  • Rested
  • Simple Websocket Client
  • Tab Center Redux
  • Tab Hunter
  • Tabliss
  • Undo Close Tab
  • Usable Home Button

(actually a lot less than I thought I had)