Alt-D does Nothing in Firefox


#1

For some reason, while visiting a page on http://bbs.boingboing.net in the latest version of Firefox (in Windows, to be precise), pressing Alt-D does nothing. Normally Alt-D activates the address bar, but it seems this keystroke is trapped. It does function normally while I’m typing in a box – or while visiting practically any other site on the Internet – but not otherwise.

I notice that on the standard Proboard layout (such as http://midi-tutor.proboards.com/ ), Alt-D pops up an in-page menu, but if such a menu was intended for the BBS, it was apparently never implemented. Perhaps the offending Javascript (if that’s what it is) could be excised?


#2

This is a question for @codinghorror


#3

Not sure, perhaps related to experimental keyboard shortcuts. Confirmed that alt+d works in Chrome but not in Firefox here. @zogstrip any thoughts?


#4

Confirmed! That was indeed the experimental keyboard shortcuts messing up with browser defaults…

Will be deployed shortly.


#5

Hooray! Thanks muchly.

If I may ask, while we’re on the subject: in the event that something like this does appear, is there some setting in Firefox that will prevent a website from overriding keys like Alt-D? (I’d love to restore normal behavior on Proboards, but I doubt the developers there will be so responsive.)


#6

Unfortunately, other than disabling JavaScript I don’t think that’s possible…


#7