Controlling your Personal Messages

Hello,

Currently, you have several options to control which users can send you personal messages:

  • By default, any full user can message you
  • There is a global option under Preferences -> Notifications called Allow other users to send me personal messages. Disabling this feature will prevent all non-admin users from being able to message you
  • Additionally, any user you add to your Mute or Ignore lists (Preferences -> Users) cannot send you personal messages (this feature was partly broken do to a recently corrected bug)

As of today, you now have a third option: Under Preferences -> Users, there is a new option Only allow specific users to send me personal messages. Activating this option will allow you to create a list of users who may message you. All other non-admin users will be unable to send you messages.

Personal messages can be much more intimate than general posts and replies, and this third option will offer further control of who is permitted to send such messages for those who wish it.

Please feel free to respond here (or via a personal message if you prefer) if you have any questions or concerns. As this is a new feature, bug reports are also welcome on this topic.

Thanks!

17 Likes

This sounds great, but I wonder about this scenario:

  • User A has no restrictions on messages
  • User B only allows messages from User A
  • User B messages User A
  • User A adds User C to the message

What is the expectation here?

1 Like

I sent this over to the discourse folks and they are investigating.

2 Likes

Question: When a user chooses to hide their public profile and presence features—presumably by doing this:

Preferences>Interface>Other>Hide my public profile and presence features

Does it automatically stop all other users from messaging them, and that’s why I don’t see a blue “Message” button on their User Card?

Or is it just that those users on whose User Cards I happen to have seen the words “This user’s public profile is hidden” have ALSO chosen to prevent all other users from messaging them, and that’s why there’s no blue “Message” button on those particular users’ User Cards?

Or is it that those users have blocked ME, and that’s why I don’t see a blue “Message” button on their User Card?


Random example of a user who has a publicly-viewable profile and a User Card with a blue “Message” button:


Random example of a user who has a hidden profile, and I see a User Card with no blue “Message” button:


Edit: punctuation

I think that button is just hidden for users who don’t have the public profiles enabled. I’ll confirm, though.

1 Like

Yes, it seems as though the message button doesn’t appear if someone’s profile is hidden. You can still message them by going into your messages area and using “New message”, and manually entering their username, however, or by using the “I want to talk to this person directly” feature in the flag menu on one of their posts.

3 Likes

Thank you for looking into it, and the clear explanation, I appreciate it.