Linux Sound Woes


#1

My laptop’s sound has done the Disappearing Linux Sound Thing. I’ve tried messing with Alsamixer, removing & reinstalling Alsamixer and Pulseaudio, removing just Pulseaudio, and various other first page of google fixes. It plays for approx 2 minutes after a reboot, then cuts out. Occasionally, but not always, it plays through the headphones, but it won’t be tricked into working by inserting & removing the headphone jack either. Wat do? It’s boiling my piss right now, like.


Linux Sound Woes II
#2

Anyone? Anyone…? Bueller?


#3

You have my sympathies… it was headaches like this that made me stick with windows for my day to day use.
When I had windows do something similar years ago now it turned out to be hardware and a motherboard replacement… luckily it was a work machine so mostly a long coffee break for me at the time.
Are you running anything else when the sound cuts out? Stressing the CPU? Some other process starting up that kills it?


#4

No, it happens just with VLC running. It’s a thinkpad X201 with an i5 and 3GB of RAM. It’s just a Thing Ubuntu Does. My desktop does it now & again too, but unmuting things in alsamixer always works there. It’s been working fine for over a year, just today it hates me.


#5

okay have you tired a different media player?


#6

No, but youtube has no sound either.


#7

Nuke it from orbit?


#8

Try running “top” in a terminal window to see if anything is hanging?
Check logs to see if anything quit? Or some other weird condition occurred?

I use two handy utilities from the KXStudio project to keep track of my audio processes - Catia and Cadence. Because I am usually running Jack, ALSA, and PulseAudio simultaneously… =:o


#9

I fuckin’ hope not, I’d have to spend ages getting Firefox back to it’s correct level of script-blocked awkwardness and reload all my bookmarks, etc. And I’d lose my tab-farm of Interesting Things. :frowning:


#10

This used to happen to me back in Ubuntu 10.04 - Java runtime conspired with Pulseaudio to crash the audio stack every 45 minutes or so. Poettering really should be kept away from writing subsystems. Pulseaudio: crapware. Systemd is the devil incarnate.

Wish I could help. It’s been ages since the problem occurred to me (and went away in 12.04).


#11

I’ve been running Debian 9 aka “stretch” for a while and haven’t had any audio problems.


#12

Gaaaaah. All yesterday afternoon dicking about with the command line to no avail, then the baby whacks some random keys and it works again…


#13

When in doubt,

amixer set Master 15 unmute
amixer set PCM 15 unmute


#14

How is it going? Did you figure out what the malfunction was?


#15

It’s just that regular Linux bug between alsa and pulse as far as i can tell. It came back, then went away again. I’m running updates at the moment, so I’ll see if that fixes it. I really wish I’d seen what key combo the baba pressed, as that worked fine.


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.