2015 anniversary badges missing


#1

So you know, I appear to have been awarded an anniversary citation for 2014, 2016, and 2017. What happened to the one for 2015? Very odd!


"The internet is all lies," eye-rolling rebel leader tells CNN on missing Russian missile tweet
The BBS Lounge
#2

Did you take a break in 2015? If not maybe the @discourse folks need to have a look (they made that change).


#3

Nope. I’ve been here nonstop since the beginning of this version of the BBS (and before, but that’s not germane to the situation here).


#4

what @chgoliz said.


#5

Calling @discourse / @techAPJ for help!


#6

Same here.


#7

I got 2015—however, I joined Dec 17, 2014, so there isn’t any gap (i.e., 2015 is my first)


#8

Hey, you (@orenwolf) split that while I was typing. And then somehow it made a reply to myself, with the same post I’m supposedly replying to. Weird.


#9

same here, i have the badge for 2014 and 2016 but not 2015.


#10

Could be a bug, @eviltrout will have to take a look.

My account is missing 2015 as well…


#11

I was going to check the SQL but the admin isn’t showing it (at least on mobile).

Maybe 2015 was a worse year than I remember…


#12

I flat out deny that 2015 occurred at all.


#13

Just more proof of the phantom time hypothesis. Can we get a ‘lived through the 19A0s’ badge


#14

We could, but it would probably only go to @beschizza :wink:


#15

That year did not actually happen.

EDIT: Man am I behind on this!


#16

Still stuck in 2015, man!


#17

It’s a bug in the algorithm I used to retroactively award it. I see what I messed up and will try to fix it now.


#18

Okay I’ve deployed a fix. When I backfilled the missing badges I worked backwards from today. I should have worked forwards from when the first badge was created.

I have a new once off job which fixes this. After it’s deployed everything should be fixed up properly in the background.


#19

Thanks, @eviltrout!

As an aside, any idea why, if you look at @TobinL’s screenshot above, his badges were granted in different months? Wouldn’t they all happen on the same day each year? Or was that part of this issue?


#20

Yes that was exactly it. I was counting backwards from when the fix was deployed (Apr 28ish), until I couldn’t award one because it has been less than a year. Now all the dates should be the same.