Funky headers on mobile


I’m not sure whether this issue is related or not - all of a sudden I have this odd little “privacy terms” icon that floats over the main page in mobile. It directs to Googles privacy terms :

(the thing in the lower right corner, exists on multiple browsers on Android)


I see it too. And tapping it expands it, but tapping it again doesn’t seem to do anything.


@orenwolf would you consider installing the add-in that allows turning off the new header behavior?

Something wrong with BBS on mobile?

I’m on a cruise ship this week, but will investigate when I return.


I’ll investigate this tomorrow.


This feature is now live. You’ll only see the checkbox under your preferences (-> Interface) on a mobile device, and has to be enabled per-device.


Thank you so much for taking the time to do this! The BBS is a so much nicer for me to use on mobile thanks to this.


Not sure why CSS changed, but this option isn’t available to me on Chrome mobile. In order to access notifications, I have to first open a thread…


Oh good it isn’t just me.
The option is there but it’s like it thinks the screen is wider than it actually is.
Also the text box to post gets hidden when the keyboard pops up.


That info (along with browser version) is likely best added to the addon topic on


Weird. I don’t have the glitch and can’t recreate it, in stock Samsung browser (Chromium mod) or in Chrome. I can get notifications both with and without funky headers.

(Dolphin, on the other hand, doesn’t load the BBS at all. Not directly or through an article’s comments. But Dolphin’s been bitchy over other sites lately, so it’s probably unrelated.)


You are on the desktop layout for some reason, switch back to mobile via the hamburger menu.

Desktop layout on a smartphone is NOT gonna be a good time.


No it is the mobile layout. I tried requesting the desktop in the discourse app and chrome and that works but everything is tiny and my old man eyes can’t read it.


Nope that’s definitely the desktop layout. Compare:

Me sizing my desktop window to a teeny tiny little eensy weensy window that’s equivalent to a smartphone viewport

Now if I switch to the mobile user agent via f12 options…


Normally I get the top screen. If I request desktop site I get.

Edit weird. I picked mobile view from the BB menu rather than the discourse app/browser and that worked after telling the app to switch back from requesting desktop. Of course I can’t get to it without requesting desktop view from the browser first.