How to stop websites from auto-playing audio and videos


#1

Originally published at: https://boingboing.net/2017/03/14/how-to-stop-websites-from-auto.html


The BBS Lounge
#2

You are doing the Lord’s work. Thank you.

Now I must return to mourning for your country’s healthcare.


#3

Intriguing. Is FlashStopper now preferable to Flashblock? Because Flashblock has been causing me all sorts of frustration. (And I still can’t figure out why certain Twitter videos stubbornly refuse to play.)


#4

…can you disable the auto-playing videos on BoingBoing then?


#5

The kirkville link starts with “http://view-source:http://”, which means it doesn’t work very well…


#6

The unspoken suffix to that sentence:

“…at work”


#7

Installed - thanks!


#8

I’ve been using FlashStopper, and it works well. I was having some issues with FlashBlock and so I switched. As a note Firefox has updated to multi-process architecture which
improves the browser’s stability, performance and security by separating tasks into processes.

The first iteration of multi-process Firefox moves NPAPI plugins, media playback and web content to child processes thus separating them from the browser’s core.

FlashStopper and Flashblock are not currently compatible with multi-process. If you are running any incompatible addons they disable multi-process automatically. This can cause problems with video playback. The recent updgrade to version 51.0.01 seems to help with this problem, but there may still be issues. FlashStopper says it is working on a compatible version.


#9

I find Flashblock to be moderately successful, except for newer HTML5 players.

From GHACKS: Do the following to block HTML5 video autoplay in the browser:

Type about:config in the browser's address bar and hit enter.
Confirm that you will be careful if the notification comes up.
Use the search at the top to find the preference media.autoplay.enabled.
Double-click on it.

Doing so once sets the preference to false which turns autoplay off for HTML elements in Firefox. You can reverse that at any time by double-clicking again, or by right-clicking on the preference and selecting the reset option from the context menu.


#10

Googled it. http://www.kirkville.com/stop-auto-play-videos-from-annoying-you-in-your-browser/


#11

So…now that I know how to stop autoplay in Chrome, how do I keep the video window from following me down the page and covering nearly 1/4 of my screen?


#12

Try clicking the little red X in the upper right-hand corner of the browser window. :wink:

Seriously, though, I’ve lost all patience with the web. When I run into any of that kind of crap that even moderately annoys me, I just close the tab and move on.

Auto-play audio/video? Close tab and move on.
Page takes more than a second or so to download 78 MB of javascript on a mobile device? Close tab and move on.
Pop-over dialog entreating me to subscribe to your newsletter? Close tab an– wait, for this one it’s actually: enter some variation of “pop-ups still suck and now so do you” formatted as a valid email address, then, close the tab and move on.

I will admit that I go out of my way to make sites I like less annoying enough that I can actually stand to read them, but for everything else, I just close the tab and move on.


#13

I hear ya, brother. Some of the news sites I read are the most guilty of the crawling video window so I’d really like to stop that. As for the others, I don’t visit them, especially the ones that require I turn off ad-blocker in order to see the page. If the ads weren’t so obtrusive I’d not need to use the blocker and I would tolerate more modest ads.

Its enough to make me want to go back to hard copy newspaper.

I like your reaction to the “subscribe” pop up…think I’ll borrow your idea.


#14

It’s not the ads, it’s the trackers. I’ll consider looking at ads if I don’t have to wait until thirty-seven different trackers finish contacting Vladivostok, Tierra del Fuego, and Ganymede every time I refresh a page.

The Tranquility addon for Firefox works pretty well for me.


#15

You can always manually kill trackers by adding them to your “hosts” file, as well as sites which host the more egregious ads.


#16

For Firefox, get Autoplay Toggle so you can turn it on and off as needed. All it does it put a button in the address bar that toggles media.autoplay.enabled between true and false so you don’t have to load about:config all the damn time.

Reason? Well, for one thing, Vimeo are idiots. For a lot of people, turning autoplay completely off makes their player not work at all. And for me it also disables animated gifs, even if you choose to play them.


#17

What happens if you don’t know which window the autoplay is coming from?


#18

Yeah, I use Disconnect which is pretty good for blocking trackers but as a result I sometimes get a lecture about ad-blockers. I find Firefox’s Reader View a decent way of bypassing that and also hiding ads/videos/other shite at the same time.


#19

I’m sure no one ever sees my impotent little email address protests. Nonetheless, there’s a tiny part of me, deep inside, that harbors the faint hope that someday, somewhere, some lowly sysadmin or social media manager will check the bounced emails report from their list-manager software and see my pain and maybe, just maybe, see the light.

Hope springs eternal, as they say. :sob:


#20