Protect yourself online with Private Internet Access VPN

Originally published at:

Great service, BUT… has anyone gotten it to work well with Subsonic and/or Plex? I’ve tried just about every guide/bit of advice I can find online but can’t get it to work.

I tried this VPN and was pleased by the speed and the level of customer service. Unfortunately I had to cancel for a refund because they could never make it work with a secure SMTP mail server. They did try, but eventually gave up. I couldn’t live with a VPN that restricted one of the things I use most online.

If you don’t need access to port 587 (or any secure SMTP) you may like this.

I use PIA as my VPN and it works pretty well most of the time. However, there are enough issues that I don’t leave it running 100% of the time. As with the previous poster, I have not been able to get it to work with an SMTP mail server.

It does function well enough for my needs that I haven’t tried other VPN providers.

Works fine with Plex on Linux Mint for me. Of course, the LAN drops so I have to use relay quality even within my own LAN, but besides that, seems to work okay on the US West server fwiw.

Hmm, that’s kind of strange. My guess is that the VPN encryption conflicted with the TLS in ESMPT – don’t know why it would, but I can’t think of anything else that could cause it.

FWIF, I use PIA under Arch Linux and I haven’t had any issues with it.

My guess is that the VPN encryption conflicted with the TLS in ESMPT

Could be. Their claim was that every SMTP host had blacklisted their servers because VPNs are a major source of spam etc. But my main provider is a private server that isn’t blacklisting anything. Then they offered to whitelist my provider by IP address, which isn’t consistent with their first claim. Didn’t work, so we parted ways.

In any case, I’ve used two other VPNs with no email problems at all.

Some leak testing by a regular on the Wilder’s Security forum:

To be honest, given the VPNs in the BB shop right now I’d be most tempted to go with Windscribe (though it isn’t in the chart above), or wait for NordVPN to be available again (and turn off ipv6).

This topic was automatically closed after 5 days. New replies are no longer allowed.