Blog View Bugged Again


#1

I see no thread about this and am not sure what else to do about it, so here goes:

All the text on http://boingboing.net/blog is boldened at the moment when viewed in Firefox. View the page source, and it is reasonably helpful about pointing out where the error lies:

Strangely, this doesn’t show up in the Inspector, where the tag is properly closed. Internet Explorer 11 isn’t bothered by it at all.

This started yesterday, sometime around when the Sanders article appeared.

@beschizza ?


#2

I don’t see bold, but the /category/post/page/2 is back to weird caching tricks, and the last 19 hours’ worth of posts disappear into a black hole.

(Right now the last post on /category/post is Corey’s post about the Kochs and the first post on ./page/2 is Xeni’s post about North Korea)


#3

Hmm. I tried with a different installation of Firefox 43.0.4 and everything looked fine, even though the same buggy source was generated. The problem may be limited to my particular copy of Firefox Portable 43.0.4. I tried disabling all my add-ons (not that there are very many) and the problem remained. There’s probably some obscure change I made in my Firefox preferences that’s responsible, which I guess means it’s a “bug” in Firefox, even if the HTML is wrong.


#4

I don’t suppose anyone has suggestions for getting to the bottom of this…? I guess the Firefox devs might like to know.

I have thus far observed that the problem does not occur in other installations of Firefox Portable, and that the problem still occurs even when Firefox is started in Safe Mode. No history or preferences are being saved. Firefox is set not to remember anything.


#5

What sick manner of sorcery is this?

I started over with a fresh copy of Firefox Portable and the page is still rendering strangely. Except the same installation of FFP renders differently on a different computer on a different network!

This is almost as much fun as the black rectangle thing.

ETA: I even get the same user agent string from http://www.whatsmyusergent.com even when BoingBoing is rendering differently.

I guess the only thing I can think of is that there might be some hopelessly obscure access permissions involved on this one computer when I’m running FFP from the USB drive.


#6

Your link is missing a letter. Corrected:

http://whatsmyuseragent.com/


#7

This topic was automatically closed after 402 days. New replies are no longer allowed.