Discourse issues in iOS Safari

Tangentially related but I’m having huge problems with the gif browser on iOS 14. It can cause the tab in Safari to hard lock requiring me to force quit or remove the tab.

(Discourse is actually pretty broken for me ever since iOS 13 in many different ways.)

3 Likes

I’d avoid using that particular optional feature for now.

I use Discourse extensively in iOS 14, plus we have hundreds of customers giving us feedback, Apple has issued two patches for iOS so far, and we haven’t seen systemic issues.

If you have other specifics and repro steps definitely let us know.

1 Like

Here’s the issues I see:

  • Disappearing counter on the bottom right of the page (seems to happen randomly)

  • Unable to click “dismiss” button when expanding the notifications view when the Safari navigation buttons on the bottom disappear. Note in this screenshot that it’s at the very bottom in an un-tappable area. Once I try to tap it, it’s covered up.

I have a video of it but I can’t seem to upload it. It uploads as a broken 1x2 gif. ¯\_(ツ)_/¯

Here’s a static image:


7 Likes

Hello @ficuswhisperer, I’m a Discourse developer, and I had a look at the two issues you raised above.

If you can track down the specific circumstances leading to this problem, let me know and I can take a look. (I couldn’t repro on a quick try…)

This should be fixed now, the dismiss button should no longer be in the very bottom right corner, it should be higher and much easier to hit.

3 Likes

Sadly I don’t have a specific sequence that causes this. I’ll be scrolling through threads and it just goes away. If I can isolate a specific pattern I’ll let you know.

Maybe it happens here more often because we often have really long threads with many deleted posts?

1 Like

@pmusaraj I think I’ve got a repro.

Once I create or edit a post, the counter seems to get pinned at the bottom of the page. I’ve been able to reproduce this multiple times.

Steps:

  • edit a post (post is the last in the topic)
  • cancel edit
  • scroll up

It seems to make a difference when the post is the last in the topic. I tried editing a post further up in the topic and couldn’t reproduce this but if I edit this post and then cancel the edit (as it’s currently the last one) I can make this happen reliably. Doesn’t seem to happen if I save the edit. I tend edit my posts a lot so maybe I’m just more likely to hit this.

Example:
image

3 Likes

Thank you, I see it clearly in the video but I can’t reproduce it on my device. I have an iPhone 11 Pro, iOS 14.1 (and I tried on Safari). Will try a few more times tomorrow.

I’m using iOS 14.1 with Safari as well. :thinking: One other thing I noticed is that before I press the edit button I need to be scrolled down a little ways.

2 Likes

I just wanted to say this works great now. Thank you for fixing this.

3 Likes

Great, that’s nice to hear.

I can’t reproduce the other issue, the counter on the bottom always shows up where it is supposed to for me…

2 Likes

Here’s another repro. Note how after canceling the reply the counter gets pinned to the last post rather than the bottom of the page.

Maybe this is happening because I’m TL4 and have the mod tools on the counter and that changes behavior?

image

1 Like

The pinning to the bottom of the last post is the expected behaviour here. (The counter does not apply to the “Suggested Topics”, so we don’t let it display below the post stream.)

What is unusual about your videos is that in some cases the counter keeps going past the “Suggested Topics”. That shouldn’t happen.

If I may report a separate issue…

Using BBS on an iPad in Slide Over view (where the window is essentially an iPhone’s width on the screen), the site isn’t re-scaling to the mobile view properly. It’s just a very crushed-down version of the full-width view.

I’m running iOS 14.1. It makes no difference whether I request the mobile or desktop version of the site in Safari.

I can reproduce the iPad issue. The main issue there is that the BBS logo is too wide, and it doesn’t shrink properly. That should be the first thing to fix.

After that is fixed, you’ll need to manually switch to the mobile view, because iPads send a regular Safari user agent name, which means that Discourse can’t detect it as a mobile device, and thus, will be delivering a desktop layout by default, even on that window width. (You can use the DiscourseHub app instead of Safari, that will deliver a mobile site by default on smaller window sizes on iPads.)

Understood. The problem is that it stays there permanently until I reload the page - in other words it stops following me if I scroll back up.

This is a problem if I reply to a post and then scroll/jump back up to the post I replied to so I can read the rest of the posts in the topic.