iOS 15 Safari woes

Running iOS 15.2. Open BB in Safari… single tab only… yada yada… inside a comment thread tapping/selecting relevant words or words to reply… highlighting works but no joy on the reply.

Sometimes it works, sometimes it doesn’t.

Trying to quote from your reply failed.

1 Like

I just used an iOS 15.2 device to quote your post and had no issues. Can you provide repro steps? Do you run any safari plugins? Does refreshing the page help? Is it a sequence of actions? How can I cause this to happen on my iOS 15.2 device?

Quote function worked just now. 50/50

I had closed and reopened Safari since previous post.

All seems like normal usage to me. No plugins, no special sauce of any kind. Just random.

Clean screen, no scratches or cracks.

2 Likes

Same here. It just happens with no real rhyme or reason - exactly as shown in my original post. Refresh usually fixes for me.

Reminder:

image

3 Likes

When I encountered this (I’m running 15.3 public beta but not sure what I was using when this happened) I was trying to pull a second quote to add to a comment I was in the middle of writing. Like @ficuswhisperer shows. This wasn’t a quote starting a new reply. Is that the case for others?

I’m running 1Blocker (content blocker, not extension), 1Password, Amplosion, and Vinegar.

1 Like

@codinghorror I think I have a 100% repro.

Go to this post:

Select exactly this text - no less, no more:

Before the Fast and Furious film series wore its absurdity on its sleeve, I thought it was trying to be serious.

(ETA: if I select this exact text in this post I can repro as well.)

No less, no more. Press “Quote”. For me 100% of the time nothing happens.

Let me know if this repros for you.

(It seems like if I select a different block of text or a different part of that block of text it works - might be something weird with text at around 100 characters?)

ETA2: Repro from this post:
image

So

  1. Enter a BB topic
  2. Expand the “show first post” in the first post
  3. Quote specific text from the expanded first post

Sadly I have no repro on my iPhone

Let me try quoting it here from your post

Nope :frowning:

I don’t know what to tell you then. I can reproduce this 100% of the time - even now. I’ll try connecting my phone to my Mac and see if I can get anything from Web Inspector.

Does it happen if you restart Safari (close the app?)… does it happen if you refresh the page? I’m very happy we have a set of repro steps for you, that is significant progress, but then the question is, what’s different about my device or account if I am following the same steps and not getting the same result?

(Am I doing it right? Did I follow the correct sequence of steps above?)

Also I am not an admin or mod here any more, so that can’t be it either… however you are TL4 (right?), so that’s one variable?

It still repros if I force quit. I am TL4 but @pfranz and some others who can repro this are not.

Using Safari’s Web Inspector I didn’t see any JS errors when trying to do this flow. One thing I did notice is no network requests went out on the failed quote, while on a successful quote there were network requests. I also tried enabling breakpoints on any exceptions or assertions and nothing triggered as part of this flow.

I also captured a timeline with a failed quotation first, and successful quotation afterward (there’s a big gap in the timeline so it should be obvious which was which). In each case I did the same thing: selected some text, tapped “quote”. I’ll DM you with a link to the timeline in the hope that this has some useful information.

So, I’ve seen the same problem sometimes if I tap on the posts indicator to move to another point in the topic. Sometimes, tapping on it just causes it to disappear entirely, in the same way that @ficuswhisperer shows above. Extremely frustrating, but I’ve never been able to reliably repro it so I never brought it up.

Also on the latest iOS safari.

1 Like

:wave: Taylor from the Discourse Team here. I just wanted to say my team and I will try to do a deep dive into this over the next few days. I do remember naturally hitting this once recently, but I haven’t had it recur since. I’ll go through everything that’s been noted here and hopefully we can get to the bottom of it!

3 Likes

Thanks! Since I can repro it pretty reliably please let me know if there’s anything I can do to assist. I am happy to debug into any JS or capture network traces.

1 Like

Also just so it’s not lost, I want to make sure that it’s not forgotten that the gif picker doesn’t work very well anymore on iOS 15 Safari. Hopefully this is simpler for you all to reproduce.

1 Like

I’ve got a good repro on our community forum and have taken it to the rest of the team. I’ll get back to you as soon as I have news!

1 Like

Turns out this is iOS “magic” based on “tapping near a previous tap”. So the fix and reproduction is… complex.

4 Likes

I’m glad you’re at least getting to the bottom of it. It’s incredibly aggravating. Is this new to iOS 15 Safari? Is there some way to opt out of this behavior?

1 Like

We are working on it, but it’s quite complex because… well, what I described is complex :wink:

Workaround for now is to make sure you are tapping in very different areas on the screen when you tap. 🤷

Aside time:

Something else that’s aggravating is that iOS’s text correction is really, really broken on Discourse’s text entry for posts. It seems like the more a post is edited or modified at any one time, the worse it gets until it basically becomes usable.

It starts suggesting garbage text, or no suggestions at all. Often times tapping a suggestion to fix text doesn’t actually apply. This isn’t new to iOS 15 but it’s no less irritating and leads to a really poor mobile experience.

Finally - any progress on fixing the broken gif picker? It’s a minor annoyance in the grand scheme of things but it’s an uncharacteristic lack of polish.

ETA here’s an example of the weird text substitution behavior:

I’m not sure – I turned off iOS text suggester years ago as it was so very annoying, and haven’t looked back since.

In the meantime, be sure your “taps” are in very different locations on the page to avoid this behavior for now.

Also, I pretty much exclusively use the native OS emoji pickers these days, on Windows, on Chromebook, on Android, and on iOS.