iOS 15 Safari woes

This seems like a good place to post this…

As of last night(?) my “read” status on threads is no longer being recorded on my iOS 15 devices. It works fine on my laptop (Safari all around). So, I go into a thread, and it loads at the top. I scroll down, “read” all the messages, then go back to the topic list and it still shows the blue bubble with unread messages. Every time I go back in, it starts at the top, unaware of my having read all those posts already. Furthermore, while viewing a thread, the thumb slider on the right no longer moves as you scroll.

The “last visit” line has also stopped updating reliably. Weirdly, it sometimes works, but not every time.

I don’t have repro steps per se, but it is 100% on my iOS 15 iPad now. I have tried rebooting the iPad, and logging in/out of BBS.

ETA: Oh geez- I just double-checked, and that iPad is stuck on iOS 12 because it’s so old. I just assumed it was on 15 (all my iOS devices auto-update). Well, maybe supporting an OS that old is a big ask (as a developer, I get it) so feel free to disregard this. I’ll add “BB BBS” to the list of reasons I need to upgrade this thing.


eeek! Sorry. Yeah, we try to support a few older versions for sure but 12 was released September 2018.

edit: we are doing some things internally to allow the HTML only view for really old versions of Safari. Stay tuned! I got your back!:+1:

“Oh nice. Correcting myself here, we are now working fine on iOS 12.2 and up. So if this user is on an iPad on 12.2 it will start working after the deploy.”

I deployed a fix for iOS 12.2 yesterday, can you please give it a try?

1 Like

The quote function is flaky AF.

Can no genius fix this?


Oh thank you!

Unfortunately it is still doing the same things. Scroll bar does move properly, large sections of each thread are blank, and it doesn’t track my “read” state. It’s okay, I ordered a new iPad which I needed anyway. I appreciate the effort, though!

1 Like

Can you give us a series of steps to reproduce the problem? When and how does it happen?

Running iOS 15.2. Open BB in Safari… single tab only… yada yada… inside a comment thread tapping/selecting relevant words or words to reply… highlighting works but no joy on the reply.

Sometimes it works, sometimes it doesn’t.

Trying to quote from your reply failed.

1 Like

I just used an iOS 15.2 device to quote your post and had no issues. Can you provide repro steps? Do you run any safari plugins? Does refreshing the page help? Is it a sequence of actions? How can I cause this to happen on my iOS 15.2 device?

Quote function worked just now. 50/50

I had closed and reopened Safari since previous post.

All seems like normal usage to me. No plugins, no special sauce of any kind. Just random.

Clean screen, no scratches or cracks.


Same here. It just happens with no real rhyme or reason - exactly as shown in my original post. Refresh usually fixes for me.




When I encountered this (I’m running 15.3 public beta but not sure what I was using when this happened) I was trying to pull a second quote to add to a comment I was in the middle of writing. Like @ficuswhisperer shows. This wasn’t a quote starting a new reply. Is that the case for others?

I’m running 1Blocker (content blocker, not extension), 1Password, Amplosion, and Vinegar.

1 Like

@codinghorror I think I have a 100% repro.

Go to this post:

Select exactly this text - no less, no more:

Before the Fast and Furious film series wore its absurdity on its sleeve, I thought it was trying to be serious.

(ETA: if I select this exact text in this post I can repro as well.)

No less, no more. Press “Quote”. For me 100% of the time nothing happens.

Let me know if this repros for you.

(It seems like if I select a different block of text or a different part of that block of text it works - might be something weird with text at around 100 characters?)

ETA2: Repro from this post:


  1. Enter a BB topic
  2. Expand the “show first post” in the first post
  3. Quote specific text from the expanded first post

Sadly I have no repro on my iPhone

Let me try quoting it here from your post

Nope :frowning:

I don’t know what to tell you then. I can reproduce this 100% of the time - even now. I’ll try connecting my phone to my Mac and see if I can get anything from Web Inspector.

Does it happen if you restart Safari (close the app?)… does it happen if you refresh the page? I’m very happy we have a set of repro steps for you, that is significant progress, but then the question is, what’s different about my device or account if I am following the same steps and not getting the same result?

(Am I doing it right? Did I follow the correct sequence of steps above?)

Also I am not an admin or mod here any more, so that can’t be it either… however you are TL4 (right?), so that’s one variable?

It still repros if I force quit. I am TL4 but @pfranz and some others who can repro this are not.

Using Safari’s Web Inspector I didn’t see any JS errors when trying to do this flow. One thing I did notice is no network requests went out on the failed quote, while on a successful quote there were network requests. I also tried enabling breakpoints on any exceptions or assertions and nothing triggered as part of this flow.

I also captured a timeline with a failed quotation first, and successful quotation afterward (there’s a big gap in the timeline so it should be obvious which was which). In each case I did the same thing: selected some text, tapped “quote”. I’ll DM you with a link to the timeline in the hope that this has some useful information.

So, I’ve seen the same problem sometimes if I tap on the posts indicator to move to another point in the topic. Sometimes, tapping on it just causes it to disappear entirely, in the same way that @ficuswhisperer shows above. Extremely frustrating, but I’ve never been able to reliably repro it so I never brought it up.

Also on the latest iOS safari.

1 Like

:wave: Taylor from the Discourse Team here. I just wanted to say my team and I will try to do a deep dive into this over the next few days. I do remember naturally hitting this once recently, but I haven’t had it recur since. I’ll go through everything that’s been noted here and hopefully we can get to the bottom of it!


Thanks! Since I can repro it pretty reliably please let me know if there’s anything I can do to assist. I am happy to debug into any JS or capture network traces.

1 Like

Also just so it’s not lost, I want to make sure that it’s not forgotten that the gif picker doesn’t work very well anymore on iOS 15 Safari. Hopefully this is simpler for you all to reproduce.

1 Like