Onebox all the links!


#41

Another onebox issue:

https://www.law.cornell.edu/uscode/text/50/3021


#42

#43

Just tried to paste this link in, and it failed.

https://thescene.com/watch/gq/if-trump-can-t-act-like-a-president-he-could-at-least-dress-like-one?source=player_scene_logo

It looked fine in preview, but the post just had a blank area with nothing in it. As below.

Even tried stripping the text in the url after the ? and it didn’t make a difference.


#44

Erm I see something in that “blank space”


#45

Ah. Ok. I disabled my adblocker because I thought that might have something to do with it, but it didn’t. So I looked around looked for something else that might make me a special snowflake, and saw that I have third-party cookies disabled. I temporarily re-enabled them, and now it shows up.

Carry on.


#46

What happened with links to BBS? They seem to be b0rked since the site was in read-only mode earlier.

They show up in the preview window fine, but not in the final post.

ETA: @beschizza


#47

Let’s see

Looks fine to me? Oh wait you are correct.


#48

Poof. Looks like it just got toggled back.


#49

Not sure why it’s not working here.


#51

Related issue? I posted (a bunch) of Twitter links, all with either GIF images or short YT videos embedded (of Our Pal Richard Spencer being punched to music, if you’re wondering why) and some of them are auto-playing. Is there a way to post a link so that it will stop autoplay? Sadly, I expect that fix to be exclusive for each domain’s link…but I’m hoping for a one-shot solution.


Neo-Nazis Attack Boing Boing Publisher
#52

Not sure why, but Onebox refuses to work on any link to The Hill website, even adding a ‘www.’ at the beginning of the url doesn’t seem to help.


#53

Sure @zogstrip can have a look.

The first port of call, as always, is http://iframely.com/debug

I think the problem in the specific case of thehill.com is that there is no text excerpt / summary.


#54

This is perhaps the least important Onebox issue ever, but Talk To Aliens In Real Time doesn’t show any preview:
https://www.ttairt.com/display.php?show=7B9737HM


#55

Here’s a neat trick. Over here I was trying to post

http://wondermark.com/c/2007-11-27-357parking.gif http://wondermark.com/357

The image previewed all right, but then when I tried to add the link and the Onebox appeared, the image suddenly shrunk to the size of the preview in the Onebox.


#56

The Reductress doesn’t seem to onebox properly:


#57

The only thing about OpenGraph that really honks me off is the lack of a date field.

I have microformat markup all over my site, but not OpenGraph.


#59

Sorry for the delay… The issue with thehill.com is that they don’t provide a description. Having a onebox with an image and a title would be pretty bad…


#61

The reductress was blocking the generic Ruby language default user agent for http get requests. We switched to a custom Discourse user agent (more correct and more informative) and now it works. Good find!


#62

Any other recent onebox issues? Anyone? Class? Bueller? Bueller?


#63

Possibly: